Security Changes

As of January 1, 2016, the NBSTSA, along with numerous websites that handle sensitive information, have put new security measures in place for your protection. If you attempt to visit a secure website with a browser that does not support the new protocols, you will not be able to pull up the page. If you are unable to access the Verify Credentials page on our website, find the operating system on your computer or mobile device below for an explanation of how to fix it, if possible.

  • Windows XP
    • Microsoft no longer supports Windows XP.  PCI compliant websites cannot be accessed from a computer that uses Windows XP.
  • Windows Vista
    • PCI compliant websites cannot be accessed from Internet Explorer on a computer that uses Windows Vista.  Switch to Mozilla Firefox, Google Chrome, or Opera.
  • Windows 7
    • If using Internet Explorer, some settings must be changed to access PCI compliant websites.  Click the start menu and type "Internet Options" in the "search program and files box" or find "Internet Options" in the Control Panel.  Click on the "Advanced" tab and scroll all the way down.  Put a check mark next to "Use TLS 1.2" and "Use TLS 1.1".  Uncheck "Use SSL 2.0" and "Use SSL 3.0".  Click the "Apply" and "OK" buttons at the bottom of the box to save the changes.
    • If using Mozilla Firefox, Google Chrome, or Opera, update the browser to the latest edition available.
  • Windows 8 and 8.1
    • If using Mozilla Firefox, Google Chrome, or Opera, update the browser to the latest edition available.  Internet Explorer is already compatible.
  • Windows 10
    • Both Internet Explorer 11 and Microsoft Edge are compatible.
  • Apple Mac OSX
    • Upgrade the operating system to OSX 10.9 or better.
  • Apple iPhone and iPad
    • Upgrade to iOS 7 or better.  If your device does not allow an iOS upgrade, it is no longer supported by Apple and PCI compliant websites cannot be accessed from it.
  • Android Version 3.0 and less (Honeycomb, Gingerbread, Froyo)
    • PCI compliant websites cannot be accessed from this device.
  • Android Version 4.0 (Ice Cream Sandwich)
    • Use Google Chrome Version 26 or better (can be found in the Google Play Store).  The Google Android OS Browser is not compatible.
  • Android Version 5.0 or better
    • This device is fully compatible.
  • Windows Phone Version 10+
    • Some settings must be changed to access PCI compliant websites.  TLS 1.1 and TLS 1.2 will need to be enabled.  SSL 2.0 and SSL 3.0 will need to be disabled.
  • Windows Phone Version 11
    • This device is compatible without changes needed.

To download the Mozilla Firefox, Google Chrome, or Opera browsers, click on the corresponding link below.

Mozilla Firefox (http://www.firefox.com)
Google Chrome (http://www.google.com/chrome)
Opera (http://www.opera.com)